User Tools

Site Tools


it_services:pf:scheduledmaintenance

This is an old revision of the document!


Scheduled Maintenance

Upgrade of machines 2015

Machines to upgrade: N/A

Reasons: Main reason is to avoid security holes and have latest libraries/software. Situation and Selection criterias Some machines also need to be changed because they are too old.

Tentative Schedule

NOTE: The expected update time for each machine is between 2 and 3 hours.

Key Definitions
WorkstationA desktop machine which people uses by sitting in front of. Usually located in offices.
Remote WorkstationA machine which people uses only through ssh access. Usually located in a server room.
ServerA machine that is used by the infrastructure, usually only accessed directly by an Admin. Usually located in a server room.

OpenSuse 11.2 to OpenSuSE 13.1:

TypeDate
machinenamemachinetype date

Status of other machines

Will NOT be updated (might be updated upon request, they will be updated in a future scheduled maintenance)

TypeOSmemory(GB)Cores

Should be substituted with new machines:

TypeOSmemory(GB)Cores

Should be removed or reassigned:

TypeOSmemory(GB)Cores

Iridium Cluster

To be scheduled.

Selection criterias

Machines with unsupported operating systems should be upgraded. However:

  1. For Workstations/Remote Workstations with memory less than or equal to 2GB, the target upgrade will be Lubuntu 12.04 (Supported until Apr, 2017 see https://wiki.ubuntu.com/Releases)
  2. For Workstations/Remote Workstations with memory above 2GB, the target upgrade will be Ubuntu 14.04 (Supported until Apr, 2019 see https://wiki.ubuntu.com/Releases)
  3. For Servers, the target upgrade will be CentOS 6 (Supported until November 30th, 2020 see http://wiki.centos.org/About/Product#fndef-f629e99f98d098d5979628e3a302a1b0579202ce-1)

Situation

OpenSuSE dropped or will drop support for most of the OS versions we have. As a result the machines are at security risk and most of the libraries will stay obsoleted and without bugfixes. Sources:

Some machines running Scientific Linux have unsupported libraries and hardware.

Planned Upgrade is either to Lubuntu 12.04 or Ubuntu 14.04 for Workstations/Remote Workstations or Centos 6.5 for Servers.

  • High Priority: Num
    • Reason: OpenSuSE 11.2 not maintained anymore
    • Of which:
      • Servers:
      • Workstations:
      • Remote Workstations:
  • Medium Priority: Num
    • Reason: OpenSuSE 11.4 not maintained anymore
    • Of which:
      • Servers:
      • Workstations:
      • Remote Workstations:
  • Low priority: Num
    • Reason:
    • Of which:
      • Servers:
      • Workstations:
      • Remote Workstations:
it_services/pf/scheduledmaintenance.1424174631.txt.gz · Last modified: 2015/02/17 13:03 by florido