User Tools

Site Tools


it_services:mf:scheduledmaintenance

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
it_services:mf:scheduledmaintenance [2017/03/15 14:49]
florido [Upgrade of vespa 2017]
it_services:mf:scheduledmaintenance [2017/03/27 15:09]
florido [Timeline]
Line 14: Line 14:
 ==== Target distribution ==== ==== Target distribution ====
  
-  * Ubuntu 16.04 will be supported until 2021 and is my preference. There will be no more +  * Ubuntu 16.04 will be supported until 2021 and is my preference. There will be no more machine update until that time.
-   machine update until that time.+
   * OpenSuSE Leap can be installed upon request. Its release cycle and support is unclear, therefore I am not supporting it anymore.   * OpenSuSE Leap can be installed upon request. Its release cycle and support is unclear, therefore I am not supporting it anymore.
  
Line 21: Line 20:
  
 ==== Status of other machines ==== ==== Status of other machines ====
 +
 +Papaya will be updated to a more powerful machine running centos7. It will run all services on a raid 1 sw disk set.
 +  * nis master
 +  * cups print server
 +  * mathematica license
 +  * intel license (if matfys buys a new one)
 +
  
 ===== Upgrade of vespa 2017 ===== ===== Upgrade of vespa 2017 =====
Line 33: Line 39:
  
 Probably CentOS7 for all machines is the best choice. Probably CentOS7 for all machines is the best choice.
 +==== Timeline ====
 + 
 +  - Update vespa.teorfys.lu.se to a new machine with CentOS7 ​
 +    * define salt states for it
 +    * install intel license server
 +    * install salt?
 +    * install tftp
 +    * install needed pxe boot stuff for nodes
 +    * %DATE% Switch old vespa frontend to new vespa frontend
 +  - Update n3 as guinea pig
 +    * %DATE% switch off n3
 +    * define salt config states ​
 +    * install slurm
 +    * test slurm interactive mode
 +    * install eb
 +    * install modules: new env must be completely based on modules, no more specific profile.sh
 +
 ==== front ends ==== ==== front ends ====
  
Line 44: Line 67:
 ==== old nodes n6-n10 ==== ==== old nodes n6-n10 ====
  
-Opteron! Will CentOS7 run on those?+Opteron! Will CentOS7 run on those? ​Test on n6
  
 ==== old nodes n11-n12 ==== ==== old nodes n11-n12 ====
it_services/mf/scheduledmaintenance.txt · Last modified: 2017/03/27 15:17 by florido