User Tools

Site Tools


it_services:pf:scheduledmaintenance

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Next revision Both sides next revision
it_services:pf:scheduledmaintenance [2015/02/17 12:03]
florido
it_services:pf:scheduledmaintenance [2015/06/30 13:21]
florido
Line 3: Line 3:
 ===== Upgrade of machines 2015 ===== ===== Upgrade of machines 2015 =====
  
-Machines to upgrade: **N/A**+Machines to upgrade: **15**
  
 **Reasons:​** Main reason is to avoid security holes and have latest libraries/​software. **Reasons:​** Main reason is to avoid security holes and have latest libraries/​software.
Line 17: Line 17:
 ^Server|A machine that is used by the infrastructure,​ usually only accessed directly by an Admin. Usually located in a server room.| ^Server|A machine that is used by the infrastructure,​ usually only accessed directly by an Admin. Usually located in a server room.|
  
-**OpenSuse 11.2 to OpenSuSE 13.1**: +^ Date ^ hostname ​^ Type ^ Memory(GB) ^ Cores ^ Operating System ^ Upgrade description ^ Impact | 
-^ ^Type^Date^ +|2015-04-28|piff|Server|2|2|Scientific Linux 5.5|Discuss with grid group - Buy a virtualization machine?| only florido | 
-^ machinename|machinetype| date| +|buy HW|fnatte|Server|1|2AMD|OpenSUSE 10.3| license server - storage: buy new HW | a user group | 
- +|buy HW|magica|Server|8|8|OpenSUSE 11.3| New services i.e. git-svn? and Update to CentOS 6, buy new HW| Everybody | 
-==== Status of other machines ==== +|buy HW|teddi|Server|1|2|OpenSUSE 12.1|Update to CentOS 6, increase mem, buy new HW| Everybody | 
- +|buy HW|winifred|Server|1|2|OpenSUSE 12.1|Buy new small machine for TV and decommission| Kitchen TV | 
-**Will NOT be updated** +| Debian 6 expires 2016 |tjatte|Workstation|2|2|Debian 6|Consider update to Lubuntu 12.04/​Debian 7 32bit | only 1 user | 
-(might be updated upon request, they will be updated in a future scheduled maintenance) +|SLC5 expires 2017|kajsa|Workstation|2|2|Scientific Linux CERN 5.11|Update to SL6?| only 1 user | 
-^Type^OS^memory(GB)^Cores^ +|SLC5 expires 2017|kalle|Workstation|4|2|Scientific Linux CERN 5.10|Update to SL6?| nobody | 
- +|SLC5 expires 2017|penny|Workstation|2|2|Scientific Linux CERN 5.10|Update to SL6?| only 1 user | 
- +|SLC5 expires 2017|phenix3|Workstation|0,​768|1|Scientific Linux CERN 5.10|Move indico server to department and decommission machine| everybody | 
-**Should be substituted with new machines:** +|N/​A|lufsen|Server|0,​512|1|Ubuntu 12.04|Change hardware| Everybody |
-^ ^Type^OS^memory(GB)^Cores^ +
- +
-**Should be removed or reassigned:​** +
-^ ^Type^OS^memory(GB)^Cores^ +
- +
-**Iridium Cluster** +
- +
-To be scheduled.+
  
  
 ==== Selection criterias ==== ==== Selection criterias ====
  
-Machines with unsupported operating systems should be upgraded. However+Machines with unsupported operating systems should be upgraded ​as follows
-  - For Workstations/​Remote Workstations with memory less than or equal to 2GB, the target upgrade will be Lubuntu 12.04 (Supported until Apr, 2017 see https://​wiki.ubuntu.com/​Releases) +  - For Workstations/​Remote Workstations with memory less than or equal to 2GB, the target upgrade will be Lubuntu/​Kubuntu ​12.04 32bit (Supported until Apr, 2017 see https://​wiki.ubuntu.com/​Releases) 
-  - For Workstations/​Remote Workstations with memory above 2GB, the target upgrade will be Ubuntu 14.04 (Supported until Apr, 2019 see https://​wiki.ubuntu.com/​Releases)+  - For Workstations/​Remote Workstations with memory above 2GB, the target upgrade will be Ubuntu 14.04 64bit (Supported until Apr, 2019 see https://​wiki.ubuntu.com/​Releases)
   - For Servers, the target upgrade will be CentOS 6 (Supported until November 30th, 2020 see http://​wiki.centos.org/​About/​Product#​fndef-f629e99f98d098d5979628e3a302a1b0579202ce-1)   - For Servers, the target upgrade will be CentOS 6 (Supported until November 30th, 2020 see http://​wiki.centos.org/​About/​Product#​fndef-f629e99f98d098d5979628e3a302a1b0579202ce-1)
- 
-==== Situation ==== 
- 
-OpenSuSE dropped or will drop support for most of the OS versions we have. As a result the machines are 
-at security risk and most of the libraries will stay obsoleted and without bugfixes. Sources: 
-  * https://​en.opensuse.org/​Lifetime 
-  * https://​en.opensuse.org/​Evergreen 
- 
-Some machines running Scientific Linux have unsupported libraries and hardware. 
- 
-Planned Upgrade is either to Lubuntu 12.04 or Ubuntu 14.04 for Workstations/​Remote Workstations or Centos 6.5 for Servers. 
- 
-  * High Priority: **Num** 
-    * Reason: OpenSuSE 11.2 not maintained anymore 
-    * Of which: 
-      * Servers: ​ 
-      * Workstations: ​ 
-      * Remote Workstations: ​ 
- 
-  * Medium Priority: **Num** 
-    * Reason: OpenSuSE 11.4 not maintained anymore 
-    * Of which: 
-      * Servers: ​ 
-      * Workstations: ​ 
-      * Remote Workstations: ​ 
- 
-  * Low priority: **Num** 
-    * Reason: ​ 
-    * Of which: 
-      * Servers: ​ 
-      * Workstations: ​ 
-      * Remote Workstations: ​ 
- 
- 
- 
- 
  
  
it_services/pf/scheduledmaintenance.txt · Last modified: 2015/06/30 13:22 by florido